Chromecast Woes

In our office, we have a slew of first generation Chromecast devices. About 16 in total and after more than a year, we have been unable to get it to work steadily. Devices appear and disappear in the network even though when I run a diagnostic check, everything works quite well.

chromecast_woes_1

Issues

The same issues that I face are that I can’t detect any of the devices when I use the Chrome pop up even though all TV screens show that the Chromecast devices are connected to the network and to the internet.

In some cases, we can view some devices and some we can’t view at all. And the issue happens to everyone and it changes mostly. For example, sometimes I can view Chromecast A, B and C whilst my colleague might only see A, C and D.

Chromecast_dongle

Troubleshooting

I have done plenty of troubleshooting steps which include setting up the router and wireless LAN controller and the access points. I got the vendor to set up the network devices to match Cisco’s whitepaper in order to get Chromecast working but it still hasn’t resolved the issue.

Even after pouring through forums and speaking with some other folks, it seems that this issue isn’t happening specifically to me but to others as well. I have subscribed to many topics in this Google forum and as you can see in their posts, many other folks are facing this issue.

For our case, we are currently using 1st generation Chromecast devices. They are all connected to the wireless network sitting on the 2.4Ghz band. AP isolation has been turned off and uPNP enabled.

The difficult thing to really troubleshoot our issues is that the error does happen all the time and it is just so extremely random.

Here are some examples of other people’s problems.

Karen Gibbs said:
yes grace got your reply, which was useless since updating and relaunching google chrome itself did not help. And yes i saw that the cast option was now integrated into the google chrome menu itself long before your reply. And yes i STILLL cannot cast from my laptop AT ALL. Despite numerous attempts to add the extension and restarting my laptop and checking this and other forums to get assistance. All i am seeing is your form or automated reply that assumes most people are ignorant about problem solving or basic trouble shooting and nothing that acknowledges that CHROMECAST HAS A PROBLEM WITH ITS OWN BROWSER, WHETHER ONE IS A WINDOWS USER OR A MAC USER! We can all cast from our phones whether it be Android or iPhone. Most of us have even resorted to unplugging the actual device and rebooting. Our chromecast backdrop shows on our TV screen. So chromecast is recognised by our network and able to cast. Yet we cannot cast from our PCs or laptops! And so many people have written on here and in other forums to say this!!! So what is google doing about this!!!!!! Your update clearly DOES NOT WORK! IT CLEARLY IS NOT COMPATIBLE WITH YOUR OWN PLATFORM AND YOU NEED TO TAKE IMMEDIATE ACTION. I dont care if this thing cost $10 or $1 as a customer who bought into an idea and a service that no longer performs the way it should I need my issue dealt with. Two to three days of not being able to use the device for the function I expected to use it for is unacceptable.

You can read more problems in which other people face in the forum link below.

Google Chromecast Forums

chromecast_woes_3

Conclusion

I have almost given up on the technology and have since relied more on using a physical cable instead of the Chromecast device. I believe that this issue most likely happens when there are multiple devices connected through a slew of multiple network devices. It probably works better if you have just a router which you are connected to and it probably is more reliable that way. Having a Chromecast unit work with enterprise related devices is a lot more difficult.

After numerous firmware and browser updates, I am still facing the same issue but hopefully, in the near future, a permanent fix will be available.